Genius Referrals - Pages may be slow loading – Incident details
All systems operational
About This Site
Welcome to Genius Referrals' home for real-time information on system status and security. Here you'll find live and historical data on system performance. If there are any interruptions in service, a note will be posted here.
Pages may be slow loading
Resolved
Operational
Started almost 3 years agoLasted about 20 hours
Affected
Genius Referrals Portal (App)
Operational from 12:24 AM to 8:22 PM
Updates
Resolved
Resolved
We just resolved the issue!
Update
Update
We implemented a fix and currently monitoring the result.
Monitoring
Monitoring
We implemented a fix and currently monitoring the result. RESTful API and Clients' Websites Services are back to normal.
Identified
Identified
We are continuing to work on a fix for this incident.
Investigating
Investigating
The Genius Portal and our Client's Portal are currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible.