All systems operational

About This Site

Welcome to Genius Referrals' home for real-time information on system status and security. Here you'll find live and historical data on system performance. If there are any interruptions in service, a note will be posted here.

Some customers seeing error messages on some pages on Genius Referrals Admin Portal

Resolved
Partial outage
Started over 1 year ago Lasted about 6 hours

Affected

Genius Referrals Portal (App)
Updates
  • Resolved
    Resolved

    A bad database query caused Genius Referrals degradation from 20:53 UTC to 2:35 UTC. This is now fully resolved.

  • Monitoring
    Update

    The rollback is complete, and the Admin Portal is fully operational again. We are monitoring the situation to confirm full recovery.

  • Monitoring
    Monitoring

    We have identified the issue and are rolling back.

  • Identified
    Update

    We are continuing to work on a fix for this incident.

  • Identified
    Update

    We are continuing to work on a fix for this incident.

  • Identified
    Update

    We are continuing to work on a fix for this incident.

  • Identified
    Identified

    We are continuing to work on a fix for this incident.

  • Investigating
    Investigating

    We are aware of problems loading some pages on the Admin Portal. We are investigating and will update here as soon as possible.