All systems operational

About This Site

Welcome to Genius Referrals' home for real-time information on system status and security. Here you'll find live and historical data on system performance. If there are any interruptions in service, a note will be posted here.

Admin Portal and Clients Websites Down

Resolved
Partial outage
Started over 1 year ago Lasted 32 minutes

Affected

Genius Referrals Portal (App)
Genius Referrals Custom Portals (Clients Websites)
Updates
  • Resolved
    Resolved

    The Genius Referrals Admin Portal and Clients Websites were down from 10:23 to 10:35 PM EST. A rollback was issued, and this problem is now completely resolved.

  • Monitoring
    Monitoring

    The rollback is complete, and the Admin Portal and Clients Websites are operational again. We are monitoring the situation to confirm full recovery.

  • Identified
    Identified

    We have identified the issue and are rolling back.

  • Investigating
    Investigating

    We are aware of problems loading the Admin Portal and Clients Websites. We are investigating and will update here as soon as possible.