All systems operational

About This Site

Welcome to Genius Referrals' home for real-time information on system status and security. Here you'll find live and historical data on system performance. If there are any interruptions in service, a note will be posted here.

Delay in delivering messages

Resolved
Degraded performance
Started over 1 year ago Lasted about 3 hours

Affected

Genius Referrals Notification Engine (Notification Service)
Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Monitoring
    Monitoring

    We implemented a fix and currently monitoring the result.

  • Investigating
    Update

    We are currently investigating this incident.

  • Investigating
    Investigating

    We have identified delays in message delivery, and are actively investigating. Messages are currently queued and will be delivered once we resolve the issue.