All systems operational

About This Site

Welcome to Genius Referrals' home for real-time information on system status and security. Here you'll find live and historical data on system performance. If there are any interruptions in service, a note will be posted here.

Issue with Advocate Login/Sign-Up on Some Portals

Resolved
Degraded performance
Started 10 months ago Lasted about 1 hour

Affected

Genius Referrals Custom Portals (Clients Websites)
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result.

  • Investigating
    Investigating

    We are currently experiencing an issue with our authentication service that is affecting the login and sign-up functionality on certain Advocate Portals. Our team is actively investigating the root cause to address the problem.

    Rest assured, we are fully committed to resolving this issue as quickly as possible to ensure a seamless experience for all our valued customers. We apologize for any inconvenience this may cause and appreciate your understanding.

    We will provide regular updates on our progress until the issue is fully resolved. If you have any questions or need further assistance, please don't hesitate to contact our support team.

    Thank you for your patience and cooperation.